Which JVM version should I target?

Which JVM version should I target?

Hey there, I‘m relatively new to Kotlin and am still wondering which jvm version I should target with Kotlin. The Kotlin faq says that I can target anything between 8 and 13. why is that? Why not 14 or 15? And I thought it was compatible with Java 6 as well for android development?

Can someone shed some light on this for me? What are the advantages and disadvantages of choosing older or newer versions? If it is performance, are there any numbers how much better it performs on newer jvm versions?

Thanks in advance!

submitted by /u/Xaaris
[link] [comments]