I made an IntelliJ plugin that converts Groovy DSL dependencies to the Kotlin DSL

I made an IntelliJ plugin that converts Groovy DSL dependencies to the Kotlin DSL

I was quite annoyed by a lot of dependencies that don’t offer a snippet for the Gradle Kotlin DSL.

So I made a plugin that can convert those

https://i.redd.it/4d0jevwgshi61.gif

Github: https://github.com/DRSchlaubi/Intellij-GradleUpdater/tree/develop

PS: I don’t actually use Kotlin 1.3.72 the demo project is just that old

submitted by /u/Schlaubiboy
[link] [comments]